aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f35b3e9..84bbc2b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -55,9 +55,11 @@ if (ENABLE_JIT)
enable_language(ASM)
target_sources(core PRIVATE
- ARMJIT.cpp
ARM_InstrInfo.cpp
+ ARMJIT.cpp
+ ARMJIT_Memory.cpp
+
dolphin/CommonFuncs.cpp
)
@@ -85,6 +87,8 @@ if (ENABLE_JIT)
ARMJIT_A64/ARMJIT_ALU.cpp
ARMJIT_A64/ARMJIT_LoadStore.cpp
ARMJIT_A64/ARMJIT_Branch.cpp
+
+ ARMJIT_A64/ARMJIT_Linkage.s
)
endif()
endif()