aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5537e6d..87200ad 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,7 @@
project(core)
+set (CMAKE_CXX_STANDARD 14)
+
add_library(core STATIC
ARCodeList.cpp
AREngine.cpp
@@ -8,6 +10,7 @@ add_library(core STATIC
ARMInterpreter_ALU.cpp
ARMInterpreter_Branch.cpp
ARMInterpreter_LoadStore.cpp
+ ARM_InstrInfo.cpp
Config.cpp
CP15.cpp
CRC32.cpp
@@ -27,6 +30,15 @@ add_library(core STATIC
SPU.cpp
Wifi.cpp
WifiAP.cpp
+
+ ARMJIT.cpp
+ ARMJIT_x64/ARMJIT_Compiler.cpp
+
+ dolphin/CommonFuncs.cpp
+ dolphin/x64ABI.cpp
+ dolphin/x64CPUDetect.cpp
+ dolphin/x64Emitter.cpp
+ dolphin/MemoryUtil.cpp
)
if (WIN32)