aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c18164..66d0461 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,7 +87,9 @@ endif()
if (CMAKE_BUILD_TYPE STREQUAL Release)
add_compile_options(-O3)
- add_link_options(-s)
+ if (NOT APPLE)
+ add_link_options(-s)
+ endif()
endif()
if (WIN32)
@@ -99,7 +101,7 @@ if (BUILD_STATIC AND WIN32)
endif()
if (ENABLE_LTO)
- if (WIN32)
+ if (WIN32 OR APPLE)
add_compile_options(-flto)
add_link_options(-flto)
else()