aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee021d9..e640a48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,14 @@ if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE Release)
endif()
+if (CMAKE_BUILD_TYPE STREQUAL Debug)
+ add_compile_options(-Og)
+endif()
+
+if (CMAKE_BUILD_TYPE STREQUAL Release)
+ add_compile_options(-O3)
+endif()
+
add_compile_options(-fno-pic)
add_link_options(-no-pie)