aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e640a48..0309725 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
project(melonDS)
-if(NOT CMAKE_BUILD_TYPE)
+if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE Release)
endif()
@@ -20,6 +20,7 @@ endif()
if (CMAKE_BUILD_TYPE STREQUAL Release)
add_compile_options(-O3)
+ add_link_options(-s)
endif()
add_compile_options(-fno-pic)
@@ -27,6 +28,10 @@ add_link_options(-no-pie)
option(BUILD_QT_SDL "Build Qt/SDL frontend" ON)
+if (WIN32)
+ option(BUILD_STATIC "Statically link dependencies" OFF)
+endif()
+
add_subdirectory(src)
if (BUILD_QT_SDL)