aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8f89c31..18f7967 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,6 +67,13 @@ endif()
if (ENABLE_JIT)
add_definitions(-DJIT_ENABLED)
+
+ option(ENABLE_JIT_PROFILING "Enable JIT profiling with VTune" OFF)
+
+ if (ENABLE_JIT_PROFILING)
+ include(cmake/FindVTune.cmake)
+ add_definitions(-DJIT_PROFILING_ENABLED)
+ endif()
endif()
if (CMAKE_BUILD_TYPE STREQUAL Release)