aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98c653a..488da81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,8 +32,14 @@ endif()
add_compile_options(-fno-pic)
add_link_options(-no-pie)
+option(BUILD_QT_SDL "Build Qt/SDL frontend" ON)
+
add_subdirectory(src)
+if (BUILD_QT_SDL)
+ add_subdirectory(src/frontend/qt_sdl)
+endif()
+
configure_file(
${CMAKE_SOURCE_DIR}/romlist.bin
${CMAKE_BINARY_DIR}/romlist.bin COPYONLY)